MyGeotab showing the wrong address

MyGeotab showing the wrong address

CAUSE

MyGeotab makes API calls with GPS coordinates to OSM/Google/HERE Maps to obtain an address. Map providers provide the address of the nearest street for the given GPS coordinates.

WORKAROUND

Switch to a different map provider in the system settings that has the correct address.

RESOLUTION

Contact the map provider to get the address returned corrected. 


****NOTE: Geotab is updating Geotab maps around every middle of the month


    • Related Articles

    • MyGeotab - Add user in database

      Please follow the below steps to add a new user in Mygeotab. Steps       1. Login to MyGeotab database       2. From the main menu, select Administration > Users       3. Click Add        4. On the Add User page: Enter a unique username or email ...
    • MyGeotab - Vehicle appearing twice on the map

      Issue       Vehicle is showing up twice in two different locations on MyGeotab. Solution       Mygeotab map search could search zones, VIN, location, and route. Therefore, it's not the vehicle that is showing up twice, but the other one is a location ...
    • Add device in Mygeotab

      Please follow the below steps to add a device in MyGeotab database. Steps Login to Mygeotab database Go to Vehicles Click on Add> Add device Enter serial number and Description Click Ok
    • MyGeotab - Adding phone numbers to receive alerts when a rule gets triggered

      This article explains how to add phone numbers to receive alerts when a rule gets triggered. Issue If a User doesn't have an email address or if they don't want to add their email to get notification when a rule gets triggered.  They can add their ...
    • MyGeotab - Review DVIR Reports

      This article explains how to review DVIR reports in MyGeotab. Steps       1. Navigate to engine and maintenance, then DVIR,       2. Under options, fill out all the necessary information (Reports can be filtered by defective, repaired or certified)   ...